Recent content by MisterRob

  1. M

    New Holland t7 speed signal not being picked up by Amazone amados unit.

    OK a solution to this today incase it happens to someone else. The radar pin solved the problem, my theoretical speed pin just would not work. It's super frustrating because I tested this albeit with sh!t wiring obviously 🤦‍♂️ The radar was outputting a strong Voltage signal the gear speed...
  2. M

    Ford Ranger - age or mileage

    I'm from NZ so it takes a bit to compute the different metrics haha. The lower mileage 3.2 would be my pick. At the rate you use it you could own it 4 years to be the same as the biturbo miles. And there's bugger all difference between px2 and px3 rangers that makes them that much more desirable...
  3. M

    New Holland t7 speed signal not being picked up by Amazone amados unit.

    There's no differing setting in the amazone box for radar/theoretical, I know what you mean on the Kuhn setup. Luckily you can set a virtual speed with this spreader so I was actually able to use it, but my speed vary alot when spreading!
  4. M

    New Holland t7 speed signal not being picked up by Amazone amados unit.

    I'm using theoretical speed. I just tested Hz across pin 2 and 7, it's the same with 1 to 7 too. I don't have an osiliscope, is there another thing I could test?
  5. M

    New Holland t7 speed signal not being picked up by Amazone amados unit.

    Howdy team, I have a niggly little problem that I can't seem to figure out. I bought a used amazone fertiliser spreader with the amados spread rate control which requires a tractor speed input to work. I get the correct cable and plug it in and I get no 'pulses' registered. I get the amazone...
Top